SignGo Home
 
  Welcome, Guest. Please Login or Register
 
  HomeHelpSearchLoginRegister  
 
Page Index Toggle Pages: 1
Omega om60 connection issue (Read 129 times)
28. Jul 2021 at 15:19

Rhys   Offline
Forum Newbie

Posts: 1
*
 
Hi guys I have just purchased a used DGI Omega -60 to venture into a larger format cutting.   I have however been unable to connect it.  I have tried parallel to usb connection on a windows 10 laptop.  I have also tried serial to usb on windows 10.  I have bought an old win7 laptop and downloaded the drivers from Wissen but it just keeps saying something like module can't be found and won't install the drivers.  The laptop makes a sound when it's plugged in but the cutter just shows as an unspecified usb 2.0.  I have tried adding as a local printer but I don't have a mentioned "wissen software program".  I read somewhere that a null modem cable with 25 pin to 9 pin adaptors would work?? So I'm at a bit of a loss.  Any help would be absolutely awesome as I don't want to keep buying adaptors and cables if they are the wrong ones.   Thanks in advance.

Just to add apparently I need a file called DGICsetup.exe if anyone has any ideas.  I've searched and can't  find it anywhere.
« Last Edit: 28. Jul 2021 at 16:21 by Rhys »  
IP Logged
 
Reply #1 - 27. Aug 2021 at 09:51

Kevin Wallace   Offline
Global Moderator
SignGo Support

Posts: 796
*****
 
Hi

The DGI USB driver is not reliable on Windows 7 and does not work at all with Windows 10.

The best solution is a USB to serial adaptor along with a compatible serial cable (such as a NUL modem cable DB9F to DB25M). The cables are pretty hard to get these days but they're currently available from wissenuk.com.

You can use a USB to parallel adaptor but it's trickier to set up. Instructions available by clicking here.
 
IP Logged
 
Page Index Toggle Pages: 1